Our teams reprocessed engagements from approximately 10:25 AM UTC to 11:15 AM UTC, and those engagements are now available for new conversions. Thank you for your patience, and please contact us for any related questions.
Posted Oct 26, 2025 - 15:02 UTC
Monitoring
The issue with processing clicks and impressions was resolved at ±11:15 AM UTC. We process new clicks and impressions normally. Our teams are working on analyzing the impact on attribution during the issue time, and we will update you about our progress.
Posted Oct 26, 2025 - 11:30 UTC
Identified
We are investigating an issue with processing clicks and impressions starting from ±10:00 AM UTC. You may experience an impact on attribution to click-based networks (non-SRN). We will share updates about our investigation progress. Thank you for your patience.